+17 votes
272 views
in Bug Report by (2.2k points)
closed by

So first of all collection and painting/writing this took me ages so please don't dismiss this as trivial I already lost hours of gameplay because of this alignment issue and it ruins the factory designs now and than and makes playing very un-satisfactory and other players probably have experienced similar but not really knew why.

I build my factory almost exclusivly on Foundation in very orderly and very compact designs often and the thing that creates the most frustration is are the Merger and Splitter and their un-aligned in/outs. You don't recognise this if you place all in the wild, but when you start placing all on foundation grids it's very problematic and ruining your fun.

Problem

To make it simple a little illustration to show you the core problem. Keep in mind this is all with the minimal conveyor curve of 2 Units (those are Snap Units on the Foundation Grid).

Only 1 of the 4 in/outs is normally useable with the minimal 2 Unit curve radius of conveyors. To see the problem better I placed a Conveyor Belt from the Splitter directly and one pole on the grid and looked from the side. Here the screen with some notes on it.

Here is the issue. The red distance creates all the problems. The snappoint on the Splitters would just need some centimeters/inches left and the world would be okay again and less "invalid shape" messages.

All three outbound connection on the splitter have this issue. I even found out every exit has a slightly different offset each a little different, I made screen but I spare me that here. The only exception is the inbound connection, which is actually more inward into the splitter as the grid needs, but this is okay, better more inward than outward.

The Merger has the same issue btw.

Here some additional examples where I just ignored the issue, but it still bothers me when I see it and sometimes it creates problems, but there were also some scenarios I couldn't implement because the issue preventent the placement of the conveyors altogether with the invalid shape/collision warning but the radius of the curve and actually 2U and possible, just not with the slightly offset connection point. Collision problems sometimes appear as well when those unaligned conveyors touched other conveyors.

Example 2

Example 3

Solution

Now if the snappoints for Outbound-Conveyors would just be offset a couple of cm/inches it would solve all those problems. And it seems this would be no problem because the inbound connection of the Splitter is actually more inwards as it needs to be and it still looks all nice and works so I guess it could be done and would help solve a couple of problems and frustration.

... and would allow perfect placement like the following image shows (with the splitter of course I could not place here).

Thanks for reading.

closed with the note: I'm closing this question now. This issue was implemented/solved with the mai-update (#1) and splitter and mergers are changed in visual representation and behaviour somewhat in june-update (#2).
by (710 points)
+1
I also can't stand the look on these. Very unsatisfactory.
by (2k points)
+2
Very good explanation!
by (10.9k points)
Well said. I've just been ignoring this problem, but I want this to be fixed

1 Answer

+1 vote
by
I'm closing this question now. This issue was implemented/solved with the mai-update (#1) and splitter and mergers are changed in visual representation and behaviour somewhat in june-update (#2).
Welcome to Satisfactory Q&A, where you can ask questions and receive answers from other members of the community.
In order to keep this site accessible for everybody, please write your post in english :)
August 28th update: We've removed downvotes! One major reason is because we don't want to discourage folks from posting legitimate suggestions / reports / questions with fear of being mass downvoted (which has been happening a LOT). So we now allow you to upvote what you like, or ignore what you don't. Points have also been adjusted to account for this change.
Please use the search function before posting a new question and upvote existing ones to bring more attention to them, It will help us a lot. <3
Remember to mark resolved questions as answered by clicking on the check mark located under the upvotes of each answer.
...