+16 votes
302 views
in Bug Report by (1.1k points)
edited by

I've been testing the game for a few hours now and have collected a whole bunch of bugs and glitches. Instead of dividing them into separate topics, I've decided to just make 1 big collection of everything.

1. Train power bug

Even if a station is powered, the station itself will not provide power to the rail, causing  every train to show 'no power'.

This issue happens every time you reload the game, so the solution to this will have to be performed upon loading every time.

Example: https://youtu.be/JFneTkaMrt4

Solution:

Dismantle any single station of your choice, connected to your rail network, rebuild it and reconnect the power line to your powergrid. Trains will restart their own autopilots automatically.

2. Structure foundation texture/decal bug

On smelters, for example, there's a a thick metal bar acting like a support at the bottom, this bar has some yellow/ black decals which will flicker in some areas of the bar.

The train station has a similar issue on the underside of 2 thin parts at the top, where the texture will flicker.

Example: https://youtu.be/XHENOiBVRvU

3. Vibrating player when trying to move back onto a belt after being pushed onto the conveyorpole at the end of a belt.

The title says it all, whenever you get pushed off a belt at the very end, you land on the conveyorpole.

If you then try to move back onto the belt by holding W, you'll start shaking/ vibrating heavily.

Example: https://youtu.be/lXIxaV1XQRs

4. 3 bars of HP when loading into the game.

Whenever you load into the game, your character will always have 3 bars of HP, regardless of how much HP you had before saving and closing the game previously.
Apparantly your HP updates to this amount as well when exiting a vehicle.

5. All icons in build menu show 'NEW' 

Every time you load the game, all icons in the menu for structures will have the 'NEW' banner overlay.

6. Splitters and mergers have different orientation points for placement

The orientation point is supposed to center the machines both vertically and horizontally at the same position, but the splitter gets placed slightly lower everywhere than the merger, causing it to look off on a belt/ on the ground.

Example: https://cdn.discordapp.com/attachments/572784151439081472/648918173864820767/unknown.png

7. Texture/ decal issues on several machines ( some related to LOD )

Many machines now have glitched or incorrectly placed textures or look very bad when far away. This is apparantly already a known issue.

Example: https://cdn.discordapp.com/attachments/572784151439081472/649195672825757696/unknown.png

8. Missing buildgun in right hand

When pressing C > F in quick succession, the left hand will hold the scanner, while the right hand comes up in the position where it is supposed to hold the build gun.
Instead, the right hand will be empty for a short moment before spawning the build gun into the hand.

Example: https://cdn.discordapp.com/attachments/572784151439081472/648987030742892575/lol.png

9. Flickering issue with red indicator for foundation

When hovering with a new foundation in the same position of an existing foundation, the icon for the new foundation turns red in that position.
However, due to weird overlapping issues, the old and new foundations being in the same spot cause the red indicator to start flickering severely, possibly to the point of inducing seizures, so beware of this.

Example: https://youtu.be/ZCMp_Iov298

10. The new 'align to nearby structure'-feature sometimes causes the blue structure indicator to vibrate.

When aiming at an existing structure with a new structure, it will align the new one to the old one to make organized building easier.

However, in some angles/ locations, the hologram will start to vibrate in that location.

Example: https://youtu.be/WgUb4IQPHfw

11. Hub components are not in the correct location inside the hub.

The hub itself has several parts which get updated as you build the hub (MAM, Hub computer, Biomass burners, workbench).

When using the new 'align to structure'- feature to build the hub, these parts will get displaced to incorrect locations relative to the hub.

Solution: This issue does not occur if you build the hub without the align feature kicking in ( don't look/ aim at a nearby structure and don't place it close to another structure )

Example: https://youtu.be/t_cgshle1Fk

by (13.6k points)
Just eat some nuts or berries and your health will be ok.
by (1.1k points)
+2
GK-Ken,  that would fall under #7, texture issues in regards to LOD so I already covered those in my existing list :)

TopNotch, They mentioned they'd fix most bugs in update#3 and I personally feel like the HP issue isnt as crucial as, say, the trains bug with power failure upon loading a game.
The other issue I'd personally prioritize before update#3 is the flickering red hologram on an existing foundation as that one may potentially induce seizures ( not sure though )
by (190 points)
+1
Ok, but to 6. you can add most of the machines, all have these little spots where they dont fit to the grid of the others.
by (190 points)
kmarkopl - I assume your joking and if so, :).  If not, it happens every time you get out of the vehicle, so there aren't enough berries in the world to cover that.

GK-Ken - I've noticed many issues with these items as well.  (Mergers and Splitters) where they just don't line up well.  Also, if they are too close, it's really hard/impossible to connect them consistently.  i.e. I can sometimes connect a miner/pump output that is 'touching' a merger/splitter and sometimes, just a few blocks over, I cannot.  This occurred 1 out of 4 times on items lined up in one of my factories.

Tomtommerr - thanks for organizing this list!  I hope your right (about them fixing) however their patch notes mentioned (rather callously) if you don't like experimental bugs, go back to early access.  That's why I made the mention.  I would agree too that it may not be top prioritiy, but I believe it's up there.  Trains not running, or trucks, would be near the top too.
by (240 points)
I always have loads of health items so that's low priority.  But I can't do much manufacturing if the trains aren't working so that's a deal breaker for serious testing on the experimental branch

1 Answer

+1 vote
by (770 points)

I'd like to add two more bugs to this list:

  1. In the build menu, the old Manufacturer model is still used instead of the updated one.
  2. New Manufacturer model does not have sound at all.
by (1.1k points)
I think nr.1 is quite common ( example: stackable conveyorpoles also still use the old model in the build menu)

Nr. 2 is a nice find, I'm guessing they'll add that in later then.
by (190 points)
Move this to a comment on the OP and not an answer?
Welcome to Satisfactory Q&A, where you can ask questions and receive answers from other members of the community.
In order to keep this site accessible for everybody, please write your post in english :)
August 28th update: We've removed downvotes! One major reason is because we don't want to discourage folks from posting legitimate suggestions / reports / questions with fear of being mass downvoted (which has been happening a LOT). So we now allow you to upvote what you like, or ignore what you don't. Points have also been adjusted to account for this change.
Please use the search function before posting a new question and upvote existing ones to bring more attention to them, It will help us a lot. <3
Remember to mark resolved questions as answered by clicking on the check mark located under the upvotes of each answer.
...