+5 votes
666 views
in Bug Report by (360 points)
Me and my friend backed up our stable save and were playing on the new experimental build update with a copy of the save and after building some machines and changing out most conveyors in our factory from mk3 to mk5, my friend crashed, and upon trying to rejoin he continously crashed... in an attempt to fix the problem I tried killing his NPC, which fell down with me being able to revive it; at this point my friend tries again to join and crashes again, but i see 2 versions of him alive... 1 that i just revived on a conveyor belt and 1 in the hub. After seeing that there were 2 versions of the same player I tried to kill 1 of them, the first one, the one on the random conveyor. After killing it my friend tries to join and he crashes again. In a last attempt to save the situation I kill the version of my friend that was in the hub and from that point on if he tries to join I crash and he gets stuck on Initializing respawn sequence.

Please note that this could not be 100% accurate as we tried to kill and join in many different positins and states.

Full crash report (The last of the many):

Assertion failed: numItemsCalc == Items.Num() [File:C:\Jenkins\workspace\I_BuildVersion-staging\FactoryGame\Source\FactoryGame\Private\Buildables\FGBuildableConveyorBase.cpp] [Line: 585]

SW:397:Build_ConveyorBeltMk3_C_719: Make sure our new calculations behave as expected: calc size = 13, actual size = 8. BestSignedDifference(12, 0)+1

0x00007fff60e4a388 KERNELBASE.dll!UnknownFunction []

0x00007ff7403641e9 FactoryGame-Win64-Shipping.exe!FWindowsErrorOutputDevice::Serialize() [c:\jenkins\workspace\i_buildversion-staging\ue4\engine\source\runtime\core\private\windows\windowserroroutputdevice.cpp:63]

0x00007ff7403225c7 FactoryGame-Win64-Shipping.exe!FOutputDevice::LogfImpl() [c:\jenkins\workspace\i_buildversion-staging\ue4\engine\source\runtime\core\private\misc\outputdevice.cpp:71]

0x00007ff7402bf538 FactoryGame-Win64-Shipping.exe!FDebug::AssertFailed() [c:\jenkins\workspace\i_buildversion-staging\ue4\engine\source\runtime\core\private\misc\assertionmacros.cpp:429]

0x00007ff73ff6e461 FactoryGame-Win64-Shipping.exe!FConveyorBeltItems::NetDeltaSerialize() [c:\jenkins\workspace\i_buildversion-staging\factorygame\source\factorygame\private\buildables\fgbuildableconveyorbase.cpp:588]

0x00007ff74157d409 FactoryGame-Win64-Shipping.exe!FObjectReplicator::SerializeCustomDeltaProperty() [c:\jenkins\workspace\i_buildversion-staging\ue4\engine\source\runtime\engine\private\datareplication.cpp:137]

0x00007ff741579d7f FactoryGame-Win64-Shipping.exe!FObjectReplicator::ReplicateCustomDeltaProperties() [c:\jenkins\workspace\i_buildversion-staging\ue4\engine\source\runtime\engine\private\datareplication.cpp:1262]

0x00007ff74157a1b4 FactoryGame-Win64-Shipping.exe!FObjectReplicator::ReplicateProperties() [c:\jenkins\workspace\i_buildversion-staging\ue4\engine\source\runtime\engine\private\datareplication.cpp:1317]

0x00007ff7415781df FactoryGame-Win64-Shipping.exe!UActorChannel::ReplicateActor() [c:\jenkins\workspace\i_buildversion-staging\ue4\engine\source\runtime\engine\private\datachannel.cpp:2763]

0x00007ff73faa7dd0 FactoryGame-Win64-Shipping.exe!UReplicationGraph::ReplicateSingleActor() [c:\jenkins\workspace\i_buildversion-staging\ue4\engine\plugins\runtime\replicationgraph\source\private\replicationgraph.cpp:1258]

0x00007ff73faa7075 FactoryGame-Win64-Shipping.exe!UReplicationGraph::ReplicateActorListsForConnection_Default() [c:\jenkins\workspace\i_buildversion-staging\ue4\engine\plugins\runtime\replicationgraph\source\private\replicationgraph.cpp:978]

0x00007ff73faa988f
by (360 points)
I also have to add, though I'm not sure if these 2 are related, but it's now the day after the original incident (my buddy isn't online so I can't test the previous issue) and just playing I happened to die and after clicking to respawn i got respawned under the map, seems under a waterfall, in the smack middle of the map. From the little knowledge I have of spawnpoints (I had a Minecraft server) I think it might be that the save somehow corrupted the spawn location and just reset it to 0; 0; 0 coords.
by
We only just started a multiplayer world with 3 players. 2 hours in we all crashed and from then on everytime someone joined the host the host would crash with this error.

2 Answers

0 votes
by
this is happening in the normal version also once my friend crashes I (host) have to completely exit the game and come back in for him to rejoin
by (150 points)
We saw this as well, if someone started crashing the host had to close all the way out. As the world got built up the crashing escalated. By the time we hit nuclear power in the experimental build the weekend of 6/15 the entire game became unplayable.
0 votes
by

This is because clients are reporting conflicting information on conveyor belts. It can be fixed by going into a save editor and deleting the mentioned belt. In this crash log that would be Build_ConveyorBeltMk3_C_719.

Welcome to Satisfactory Q&A, where you can ask questions and receive answers from other members of the community.
In order to keep this site accessible for everybody, please write your post in english :)
August 28th update: We've removed downvotes! One major reason is because we don't want to discourage folks from posting legitimate suggestions / reports / questions with fear of being mass downvoted (which has been happening a LOT). So we now allow you to upvote what you like, or ignore what you don't. Points have also been adjusted to account for this change.
Please use the search function before posting a new question and upvote existing ones to bring more attention to them, It will help us a lot. <3
Remember to mark resolved questions as answered by clicking on the check mark located under the upvotes of each answer.
...