+1 vote
73 views
in Bug Report by (120 points)
edited by

Upon changing one of the controls back, all of them switched to display my settings. [11/04/19 ~01:50 BST]

In other words, the controls did not reset after reload but the options screen displayed the default control scheme until updated

NOTE: When I first clicked "Move Forward" and pressed [Up] the game did not display the "Rebinding Conflict" message, indicating that the game didn't have [Up] logged under anything. At this point the controls all switched to my settings. When I then clicked "Move Backward" and pressed [Down] the game did display the "Rebinding Conflict" message, indicating that the game did now have [Down] logged as taken

In other words the options menu behaved as if the default settings were in use until updated by me changing a control after which it behaved as it should if my controls were in use

So on the upside I don't need to change all my controls back. On the downside I've spent ~1.5 hours writing a bug report and not playing Satisfactory. [11/04/19 ~02:10 BST]

Original report


When I exited Satisfactory [10/04/19 ~14:00 BST] and reopened it [11/04/19 ~00:30 BST], updating in the process, I found some of my settings had changed. Below is a full list


Options:
> Gameplay:
> > "Send gameplay data" - Was unticked but reset to ticked.
> > Other options - may or may not have been reset, I left them on default.
> Audio: - May or may not have been reset, I left them on default
> Video:
> > "Vsync", "Texture Quality", "Shadow Quality", "Post Processing", "Motion Blur", "Anti Aliasing", "VFX Quality", and "Foliage Quality" - Remained as I had set them.
> > Other options - may or may not have been reset, I left them on default.
> Controls
> > "Hold to sprint" - Remained as I had set it.
> > "Move Forward", "Move Backward", "Move Right", "Move Left", "Turn Right", "Turn Left", "Interact", "Inventory", "Resource Scanner/ Vehicle Menu", "Sprint", "Dismantle", and "Build Gun Snap To Guide Lines" - Reset to default.
> > Other options - may or may not have been reset, I left them on default.

Thankfully I noted my changes and once I've sent this bug report I can easily reinstated my control scheme and start playing Satisfactory again. [11/04/19 ~01:50 BST]

NOTE: when I went to reopen Satisfactory, it updated itself automatically. The launcher didn't label this as "Updating" but as "Installing" which, combined with the reset controls made me think my save had been lost. I appreciate that's likely a decision on EPIC's side though.

Welcome to Satisfactory Q&A, where you can ask questions and receive answers from other members of the community.
In order to keep this site accessible for everybody, please write your post in english :)
August 28th update: We've removed downvotes! One major reason is because we don't want to discourage folks from posting legitimate suggestions / reports / questions with fear of being mass downvoted (which has been happening a LOT). So we now allow you to upvote what you like, or ignore what you don't. Points have also been adjusted to account for this change.
Please use the search function before posting a new question and upvote existing ones to bring more attention to them, It will help us a lot. <3
Remember to mark resolved questions as answered by clicking on the check mark located under the upvotes of each answer.
...