+26 votes
781 views
in In-Game Help by (150 points)
It is as the title says, each time the game autosave then my fame freeze up for a couple of seconds and I have no idea what to do about this.
by
+1
The game should rapidly copy the game state in memory, then save the consistent copy to disk on a separate thread.  Sniper Elite 4 does this because it doesn't halt for autosaves
by (330 points)
+2
Adding my request for this to be bumped in priority! This is starting to
A) Get very annoying
B) beginning to really interfere with game play as I build more (saves get longer) as its starting to result in deaths. Jump, fighting if a save interrupts these things have really come close to dying, or have killed me.
by (110 points)
+1
I have the game installed on a brand new 1TB Samsung 970 Plus M.2 drive that surpasses 150k IOps and I'm still experiencing game stutter every time it autosaves. There has to be more to the 1-2 second delay than just save size.
by (330 points)
From what I've seen, it is the save size, as I add significantly more to my game (building) the file size is bigger, and the save stalls are much longer. At this point, I get about a 7 second delay. New game, no delay, in fact as I progressed in my new game, I could see the save stall getting longer and longer.
by (420 points)
im literally to the point of parking my game progress because of the near hart attack  freeze that the autosave is causing my system.. and yes.. its on an SSD

3 Answers

+4 votes
by (300 points)
edited by
There needs to be a visual indicator for autosaving at least to avoid the stutter confusion.
+3 votes
by (8.7k points)
I'm afraid this is fairly normal across any game that has autosave, unless you have a superfast system and an ssd drive.

You can turn autosave off to prevent it, but of course you will need to remember to save the game manually.
by (450 points)
How to turn off autosave?
by (390 points)
+1
Even running from a higher end system and SSD, the autosave tends to lag the game harder the more you build and the larger the autosave gets as it can be a large write. Optimally, the save files should be chunked up and updated progressively in the background.

A feature to disable or set the interval for when autosaves take place would be ideal as work-around until this can be optimised.
by (8.7k points)
Yes, I agree.  I assumed that you could turn off autosave, but apparently in this game you can't.  This is definitely needed, as well as the ability to change the interval between auto saves.
by (390 points)
+3
It's actually really useful to have a rolling backup every 10-15 minutes in case of something happening or if you really screwed up and want to quickly roll back. The main thing that the devs should focus on is making these autosaves stream the write instead of just performing dirty dumps like we're currently seeing.

I suspect those with newer SSD's with larger caches will not see it until their saves start matching or exceeding the cache size for their drive. For the rest of us, once you hit that sweet spot of saves growing 32 to 64mb and larger, the performance hit becomes becomes apparent. And this is only compounded if you're on a slower mechanical drive.

One work-around would be to hold the save to memory then pass writes in under 8mb chunks in the background as the next autosave will be minutes out. The only critical drawback to that would be if something catastrophic were to happen during that write, but it's a fair trade with only ~15 minutes lost.
by (1.9k points)
+1
How to turn off Autosave:
In game, hit ESC to get the menu. From there >> Option >> Gameplay >> Autosave Interval (minutes).
I believe the default is 5 mins. Bring it down to nothing and the indicator will show "Off".
I've set mine to 20 mins. Less annoying. I have an SSD and I still get a 2-3 sec freeze each autosave.
As many people have stated, as the factories get bigger and bigger the longer the autosaves take. Being a programmer myself, I know this is one of those problems you can't really foresee until the masses start using your app and report the problem. But now that we've made the good folks at Coffee Stain Studios aware of it, hopefully they'll look into it and find a more efficient way of going the autosaves.
+2 votes
by (150 points)
As of June 2nd and the Nuklear update the problem still exists. On my system there is a freeze for about 1 second every 5 minutes (i asume the autosaves).

These interruptions are taking my last nerve.

My system is:
Windows 10 Pro
Intel Core i9 9900K (Coffee Lake) Socket 1151 LGA
ASRock Z390 Phantom Gaming 9 mainboard
32 GB DDR 4
Nvidia GeForce GTX 1080
SSD Samsung (SATA)
Welcome to Satisfactory Q&A, where you can ask questions and receive answers from other members of the community.
In order to keep this site accessible for everybody, please write your post in english :)
August 28th update: We've removed downvotes! One major reason is because we don't want to discourage folks from posting legitimate suggestions / reports / questions with fear of being mass downvoted (which has been happening a LOT). So we now allow you to upvote what you like, or ignore what you don't. Points have also been adjusted to account for this change.
Please use the search function before posting a new question and upvote existing ones to bring more attention to them, It will help us a lot. <3
Remember to mark resolved questions as answered by clicking on the check mark located under the upvotes of each answer.
...