+122 votes
32.3k views
in Bug Report by (150 points)
A friend and I cannot join eachother in multiplayer.

On invite or join (via the menu) we see a popup window "Joining online session" followed by a loading screen. Afterwards a loading screen appears and after a few seconds the game drops back into the main menu.

The game says "NAT: Moderate" for me and "NAT: Strict" for my friend. It does not work in either way, regardless of who hosts the game.

Are there any ports we have to open or something like that?
by (540 points)
Yeah I have this problem as well
by (540 points)
+1
Was this fixed in experimental  hotfix 3?
by (220 points)
+1
Just to reiterate here, multiplayer is the main reason some people play the game, so I really think the devs should look hard into these issues.

For a long time up to about two weeks ago, every time I played with my friend we had to give it a few tries before being able to join. Requests would time out, but after some tries it would eventually join. After the last update this changed, we have tried on several different days, and no matter how many times I attempt to join his game, it just doesn't work.

This last Friday, April 31st, for some reason I joined on first attempt and we were able to play without any issues. We tried again the next day and then again yesterday, on both occasions I kept trying to join his game for over half an hour. We tried lots of different suggestions from this thread, but nothing works.

Please look into this.
by (110 points)
+1
" commented Mar 22 by Bongwasserfisch (880 points) :
you guys tried this ?

https://www.reddit.com/r/SatisfactoryGame/comments/b32t5q/multiplayer_is_completely_useless/

disabling "send game data" in options ?
for some ppl it worked"

OMG Thanks !! This worked for us. We both unticked that box with my buddy, and I connected really quickly. :D

We have the same build and the same NAT setup by the way.
by (110 points)
Same here ... please take care of this

5 Answers

+6 votes
by (1.4k points)
Not necessarily a bug of this game, just an issue with you & friends network

You'll need to port forward as the other answer suggests, the port that resource monitor states it's using is: 65017 however I'd recommend forwarding 65000 - 65100

it could also be 443, but I'm not sure

https://i.imgur.com/23DgOqh.png
by (870 points)
i also found for epic launcher 5222, 50613 udp, 6666 udp,  
for satisfactory 54663 tcp, 54672 tcp and 54676 tcp
by (100 points)
I have full control of my network, and even applying full DMZ to my computer's IP and disabling the firewall on my computer does not change my NAT type from Moderate to Open.

Something weird is happening here.
by (150 points)
edited by
+1
Same here. Regardless of which ports I open, nothing changes at all.

Maybe my provider does some weird stuff in their part of the network, but of course I have no chance to change anything there.

Edit: Just tried installing a HTTP server to make sure port forwarding works on my router: It does. Was perfectly able to connect to my machine using port 80 after opening it on the router.
by (1.5k points)
443 is the SSL Port. (Secure Socket Layer).
+5 votes
by (810 points)
I'm experiencing the same with a player on my local network (with any combination of connecting via VPN or not). I can't connect to them, they can't connect to me, but other players CAN connect fine.

The real bugger is it *does* work at random about 1 in 30 tries. This is all with the usual firewall exceptions, do not send game data and ultra networking settings in game.

To all those saying "not the game's fault, its your network, use port-forwarding", the devs have specifically said their multiplayer will work without any need for port forwarding, so this DEFINITELY constitutes a bug.
+4 votes
by (160 points)
reshown by
IT WORKS WITH HAMACHI!!!
by (150 points)
Simply setup a hamachi network with your friends and make sure the network host (the one who creates it) can have a direct (not relay) channel to each other person on the hamachi network (the hamachi client will show that state). Then this guy (the network host) hosts a Satisfactory game and voila: It works fine.

The crashes during MP are a separate problem, but devs announced that MP would not be stable for this weekend. Thus it is okay for me.
by (120 points)
Whe done that but when I try to join him my game do literally nothing. Else when my friend join me his game crash
by (870 points)
edited by
are you connected via a ds-lite tunnel or does your router have a real ipv4 - there could be an issue with that, because as a usual customer we (back in germany) do not have a that - we have a ipv4 over ipv6 - so we are tunneld onto a ipv4 server , which means we got a shared ipv4 (we share the ipv4 with like hundreds of ppl) and so there could be a routing proplem.
i had mayor problems setting up a vpn...
And hamachi is....erm....vpn afaik
the same network is not a reason why it must work - what if this game always needs to have an internetconnection because epic launcher is handling the serverlist and is managing the connection ? your ingame friendslist is a hint. its like - you - lan - router - internet - server - internet - same router - same lan - buddy ? the game is not forced to make a direct connection via lan...
by (2.1k points)
+2
We had the same initial problem with a friend too.  We tried Hamachi and the game finally loaded fine (btw we tried every fallowing step multiple times changing the person hosting).

However once loaded, the person joining was either unable to move, or could not interact with the enviroment or the machines without crashing.
The wierd thing is that the person hosting was seeing the person move and interact just fine (picking up leafes for exemple).

Hope this gets fixed for early access lunch as building together is even more fun.
by (100 points)
We tried hamachi, but it doesn't work either... we are frustrated :( we tried port forwarding and all that stuff.
+3 votes
by (870 points)
afaik the primary port for the ue4 engine is 7777 and sometimes 7778 too.

hope that helps
by (150 points)
How does NAT restrict connecting to other players? Afaik NAT is only of any interest, if you actually HOST the game (meaning other players to connect to your machine).

I did disable Windows Firewall completely, opened all mentioned ports for both TCP and UDP on my router. The game still says "NAT: Moderate" and connections still fail.

So my guess is that these are not the correct port numbers...
by (870 points)
edited by
i also found for epic launcher 5222, 50613 udp, 6666 udp,  
for satisfactory 54663 tcp, 54672 tcp and 54676 tcp

so you might wanna forward 54600 to 54800 ? ports climbing higher the longer i remain in menu - hahahahaha
so it might be 54600 to 55000 - i have no clue man - its pretty wierd

443 is also shown as remoteport
by (1.5k points)
What the christ?  NAT  "strictness" impacts server lag?
This "strict/moderate/open" bullshit just hides the truth.  Can we get an actual description of the problem and the solution directly from the devs, for the people who understand networking?
by (870 points)
its not about serverlag - its about establishing a stable connection
by (870 points)
Afaik NAT is only of any interest, if you actually HOST the game (meaning other players to connect to your machine).
 Simply - no....
0 votes
by (200 points)
I think i found a solution! Make sure you and your friend have the same build version (You can look it up by going to the main menu and checking the down right corner of your screen)
Welcome to Satisfactory Q&A, where you can ask questions and receive answers from other members of the community.
In order to keep this site accessible for everybody, please write your post in english :)
August 28th update: We've removed downvotes! One major reason is because we don't want to discourage folks from posting legitimate suggestions / reports / questions with fear of being mass downvoted (which has been happening a LOT). So we now allow you to upvote what you like, or ignore what you don't. Points have also been adjusted to account for this change.
Please use the search function before posting a new question and upvote existing ones to bring more attention to them, It will help us a lot. <3
Remember to mark resolved questions as answered by clicking on the check mark located under the upvotes of each answer.
...